Degraded performance in North America

Incident Report for Lt

Resolved

This incident has been resolved.
Posted Mar 26, 2025 - 14:09 NZDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 14, 2025 - 16:05 NZDT

Investigating

We are currently investigating this issue.
Posted Mar 14, 2025 - 10:10 NZDT
This incident affected: Region (North America).