AWS Outage impacting our services

Incident Report for Lt

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 23:27 NZDT

Monitoring

An Amazon Web Services outage has been impacting our services for the last 2 hours, including our ability to update this page. Now that AWS are seeing signs of recovery our services are returning to normal. We will continue to monitor the situation.
Posted Oct 20, 2025 - 22:31 NZDT
This incident affected: Services (Accounts, Instance) and Region (North America).