Service Disruption
Incident Report for Lt
Resolved
This incident has been resolved.
Posted Feb 06, 2021 - 22:51 NZDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 06, 2021 - 19:47 NZDT
Investigating
We are currently investigating this issue.
Posted Feb 06, 2021 - 16:50 NZDT
This incident affected: Region (North America).